VERIFIED SOLUTION i

Errors in Vault datarouter log 25219; 10061

5.3

Issue

Renders aren't starting, or documents can't be viewed in Vault interface

Cause

09:29:29 starting Renders ... 
09:29:29 
09:29:29 [ 1 / 3 ] Rendering Engine ... 
09:29:30 ERROR 25219: unable to connect to 127.0.0.1:7004, error [10061] 
09:29:31 ERROR 25219: unable to connect to 127.0.0.1:7004, error [10061] 
09:29:31 running command [ E:\Group1\e2\vault\Render\render.exe ] 
09:29:31 success starting : E:\Group1\e2\vault\Render\render.exe. PID: 14148 
09:29:33 
09:29:33 [ 2 / 3 ] Rendering Engine ... 
09:29:34 ERROR 25219: unable to connect to 127.0.0.1:7005, error [10061] 
09:29:35 ERROR 25219: unable to connect to 127.0.0.1:7005, error [10061] 
09:29:35 running command [ E:\Group1\e2\vault\Render1\render.exe ] 
09:29:35 success starting : E:\Group1\e2\vault\Render1\render.exe. PID: 7452 
09:29:37 
09:29:37 [ 3 / 3 ] Rendering Engine ... 
09:29:38 ERROR 25219: unable to connect to 127.0.0.1:7006, error [10061] 
09:29:39 ERROR 25219: unable to connect to 127.0.0.1:7006, error [10061] 
09:29:39 running command [ E:\Group1\e2\vault\Render2\render.exe ] 
09:29:39 success starting : E:\Group1\e2\vault\Render2\render.exe. PID: 13536 
09:29:43 
09:29:43 Checking started Rendering Engines ... 
09:29:47 
09:29:47 Waiting [ 10 seconds ] for server's ready ......

Resolution

UPDATED: October 18, 2017
This datarouter log shows that they have three renders


09:29:29 [ 1 / 3 ] Rendering Engine ... 
09:29:30 ERROR 25219: unable to connect to 127.0.0.1:7004, error [10061] 
09:29:31 ERROR 25219: unable to connect to 127.0.0.1:7004, error [10061]

Error 10061 is a windows operating system message.  you can type:

net helpmsg 10061 to get the meaning of this error:
 
C:\>net helpmsg 10061
 
No connection could be made because the target machine actively refused it.

This can happen if the port is being blocked, or the PC on the target IP is down.

In this case 
 
09:29:31 running command [ E:\Group1\e2\vault\Render\render.exe ] 
09:29:31 success starting : E:\Group1\e2\vault\Render\render.exe. PID: 14148 

indicates that eventually the render was able to start successfully.  Sometimes you'll see error in the datarouter log only because of a timings issue.  In later versions of Vault like 6.1 this is much rarer.

If you find that the renders are up on the proper ports and users can view documents that means that render started successfully and this error isn't anything to worry about.