VERIFIED SOLUTION i

Resolving EngageOne Server error Server mode is not covered by your keycode

Software Affected: EngageOne Server
Product Feature: License Activation Issues
Operating System: AIX
 

Issue

When EngageOne Server is restarted on a machine that has been temporarily out of service, an error is thrown about Server Mode not being covered by the Keycode

Cause

Hardware issues encountered on the original server, so Engage One was switched to a temporary server.

When the original server was repaired, and Engage One restarted, errors about Server Mode were reported, and the keycode ops file was 0 bytes

Resolution

UPDATED: October 24, 2017
When the Engage One server is started, it registers the keyfile in use.

If a temporary keycode has been used that expires during the downtime, when restarted, the invalid or expired keycode will not write correct information to the keycode ops file.

Server key needs to be re-registered with a valid keycode.  If this does not work, you may need to update the keycode.ops file manually, which is located ...\...\..\EngageOne\active-drive\license