VERIFIED SOLUTION i

Resolve raster engine unable to recognize image file format error in MapInfo Discover

Issue

Raster engine unable to recognize image file format

Cause

1. File(s) associated with the grid/raster is missing.

2. (MapInfo Discover 32-bit only) You may be opening a TAB file created or modified in MapInfo Pro or MapInfo Discover (64-bit).

3. You may be attempting to open an ERMapper ALG raster file type.

4. You may be attempting to open a Mapinfo Raster MRR file type in MapInfo Pro or MapInfo Discover 32-bit. 

5. The grid handlers may not turned on.

6. MapInfo Pro grid handlers are lost or corrupted.


 

Resolution

UPDATED: March 30, 2017
These resolutions correspond to the numbered causes above.


1.  Ensure all the files associated with the grid/raster is located in the same folder and not missing, especially the data file that has no extension.

2.
 (MapInfo Discover 32-bit only) Recreate the TAB file by opening the source grid.

In the File > Open dialog, set Files of Type to Grid Image and browse for the source grid.
Click Open, A prompt "Table definition already exists. Overwrite it?" will be display. Accept this by pressing OK.

 
3. Open the ALG file in a text editor like Notepad to determine which file it is opening. An ALG file is simliar to TAB file in that it contains no data but only references other data files to open. Typical ALG files reference an ERS or ECW file. These ERS or ECW files can be opened using
  • File>Open>Raster or Grid Image options (MapInfo Discover 32-bit)
  • Discover >Import and Export >ALG/ECW/JPEG2000 Import (MapInfo Discover 32-bit)
  • DISCOVER >Import > ECW/JP2 (MapInfo Discover 64-bit)
4. Convert the Mapinfo Raster MRR file to a format that is supported in MapInfo Discover 32-bit using RASTER > Convert in MapInfo Discover 64-bit.​

5. Ensure grid handlers are ticked on under
  • MapInfo Discover (32-bit) - Surfaces > Grid Handler Preferences 
  • MapInfo Discover (64-bit) - PRO > Options > MapInfo Pro Raster - Preferences > Raster Formats.
6. Reinstall the program. See "How to install or upgrade Mapinfo Discover bundle".


If the issue is still not resolved, contact client support.
 
 
Environment Details
Products affected: MapInfo Discover 32-bit bundle, MapInfo Discover 64-bit