VERIFIED SOLUTION i

Error "Keycode with specific prefix already exists" when updating a license in EngageOne Designer

Product Affected: EngageOne Designer

Issue

The user is receiving the following message when attempting to update a license in EngageOne® Designer:

 "Key code with specific prefix already exists"

Which prevents the user from installing the new key.

Cause

There can be only one keycode for each component within Designer.
 
The message "keycode with specific prefix already exists" will occur if the license tool already shows a key with the same prefix (for example AN- for Designer, EN- for Generate on Windows).
 

Resolution

UPDATED: November 9, 2018
It is necessary to remove the existing key before entering the updated key.