VERIFIED SOLUTION i

Issue connecting to server port 8443 using secure connection via Spectrum's management console

Issue

Cannot connect to server on port 8443 while using secure connection through management console or welcome page.

Cause

All of the below will not allow the secure connection to the Spectrum server through port 8443:

The certificate is bad or the keystore created is faulty.

The SSL file being incorrectly named spectrum-override-ssl.xml.

The spectrum-override-container-ssl.xml is configured incorrectly.

Resolution

UPDATED: February 13, 2015
To thoroughly inspect for faults, assure each point is verified.

1. In management console the port specified for a secure connection is inputted. (Default is 8443)

2. The Secure Connection checkbox is checked. (As shown below)
Generic screen shot of management console with secure connection checkbox checked.

3. The old SSL certificate is uninstalled.

4. The The new SSL certificate is properly imported into the keystore in the \Pitney Bowes\Spectrum\java\bin directory.

5. The SSL.xml file is in the Pitney Bowes\Spectrum\server\app\conf\spring directory and named  spectrum-override-container-ssl.xml.

6. In the spectrum-override-container-ssl.xml file, the directory of the keystore and the port number are properly configured.

7. Be certain there are no port conflicts as this could cause other unrelated issues.

Steps on how to setup a secure connection on Spectrum are also included in the Spectrum user guide.

If the issue is unresolved after following these steps, contact technical support for further assistance.