VERIFIED SOLUTION i

Resolving not being able to connect to Portrait Dialogue

Issue

Cannot access Portrait Dialogue

A Dialogue Admin error message pops up saying:
Error occurred when trying to connect to
'MHDialogServer.MHInternalAdminSupport@ABC1-BBB-CCC' : The
Server process could not be started because the configured
identity is incorrect.  Check the username and password.


 

Cause

This has been known to start happening on existing installations when a password has expired, or a database is down, or otherwise not reachable.
 

Resolution

UPDATED: November 1, 2017

Restart COM+ (The com+ is in component services)
Assuming you are on a server, go to: 
Server Manager/Application Server/Component Services/Running Processes
There should be a MH Dialog Server process running. 

If this process is not running then go to:  
/Application Server/Component Services/COM+ Applications
open the tree, right click on the MH Dialog Server and select start

Confirm that the database is started/running

Another thing you can try is to right click on the database instance in Dialogue Admin and select Start or Restart.  It may be that you only have to reconnect Dialogue database instance to the database.

Confirm the ID that the services are running under, either that password has expired, or the permissions that that users permissions have been changed.

Perhaps the identity used to set the COM+ package MH Dialog Server has a new password.
If you right click and choose "Properties" you can go to the identity tab and check the id the service Is running under. If that is still a valid admin user then try re-entering the password.

Also check the Windows services (Adminstrative Tools -> Services) the 3 services are MH Dialog Manager Service, MH Send message services and MH Receive Mail Service.
Check the identity on those as well.

 
Environment Details