VERIFIED SOLUTION i

"ERROR 23031: insufficient space to store report or custom attribute" in EngageOne Vault

Issue

The below error is encountered when trying to ingest a file into Vault.

ERROR 23031: insufficient space to store report or custom 
attribute [|bankaccountnumber|123456789012346|] 
ERROR 10114: document build failed for file 
[work/201309181026-qsysbankletr.drp] 
 

Cause

One cause could be:

Reports and custom attributes are stored in a limited area in the standard document record.
This area has a capacity of 2048 bytes,
Each report takes (13 + the number of characters in the report name) bytes.
Each attribute takes (16 + the number of characters in the attribute name + the number of characters in the attribute value) bytes.
If the reports/attributes being added exceeds the 2K capacity, you will encounter an ERROR 23031.


Another cause could be because the tag logic element used for detecting account boundaries (e.g TLE_BANK_CIF_CUST_NUM) is blank.
Vault detects the TLE but because the value is empty it ignores it.
It finds other TLEs such as bankaccountnumber and date.
Since the account TLE isn't triggered, it accumulates these values in one record.
Eventually that record's capacity is reached and the "ERROR 23031: insufficient space" is encountered.
 

Resolution

UPDATED: July 18, 2019
Ensure that the reports/attributes data does not exceed the limit.

One possible workaround is to use unicode document records such as uxmljournal instead of xmljournal or ujournal instead of journal.
The unicode document record has a much higher limit than the standard record.
However, there is no Unicode mode for the generic document builders.