VERIFIED SOLUTION i

Resolve issue where Email Delivery Bounce Status is not updating in Sent Individual Page in EngageOne Digital Delivery, formerly eMessaging


 

Issue

In the application logs, a data truncation error is observed and the Delivery Bounce Status is not getting updated in the Sent Individual Page.

Cause

This issue can occur if the bounced mail email status code length is more than is permissible.

eMessaging expects status up to 11 characters but with Iron Port (third party Email security provider), this limit was exceeded.

That is why the status was not updated in the database and the truncation error in the log appears.

Resolution

UPDATED: November 7, 2017
Length of column outbound_message.status_code, which stores status code can be increased as a workaround.

With Iron port, it is recommended to have length of this column as 30.