Error 7 on the DM100i-DM475 and DM Infinity

Error 7 occurs when your meter does not refill. Restart your meter to resolve this issue.
Products affected:  DM100®i, DM125™, DM200L™, DM225™, DM300C™, DM400C™, DM450C™, DM475™ and DM Infinity

Issue

The meter displays error code 7 and does not refill.

Cause

There was an issue refilling your meter.

Resolution

Error 7 occurs when your meter does not refill. Restart your meter to resolve this issue.
  1. Unplug the power cord
  2. Wait three minutes
  3. Plug the power cord back in, ensuring that it is plugs directly into a wall outlet
  4. Connect to add postage or download updates
Use the Contact Us options below if you need further assistance. Have your model and serial number ready.

UPDATED: May 06, 2021