Resolve stuck on "initializing" on the mailstation series
Learn how to resolve when a mailstation or mailstation2 is stuck on "initializing" and does not display your home screen.
Products affected: mailstation™, mailstation2™
Issue
Your meter displays "initializing". Your home screen does not display.
Cause
Your internal meter software has malfunctioned.
Resolution
Solution 1
Follow these steps to restart your meter safely:
If a restart does not resolve your initializing error, your meter may require on-site service.
Follow these steps to restart your meter safely:
- Unplug the power cord.
- Wait one to three minutes.
- Plug the power cord back in, ensuring that it is plugged directly into a wall outlet.
If a restart does not resolve your initializing error, your meter may require on-site service.
- Use the Contact Us options below if you need further assistance. Have your model and serial number ready.
UPDATED: August 14, 2021