LACSLink, DPV and Suitelink database versions compatible with Finalist 9.x

Products Affected;  Finalist

 
Version 2.0 of the LACSLink, DPV, and Suitelink databases is compatible with Finalist 9.x software.
UPDATED:  September 9, 2019