VERIFIED SOLUTION i

Basic guidelines on using the Browser in MapInfo Pro

MapInfo Pro v11.5, MapInfo Pro 12.5 32bit, MapInfo Pro 15.0 32-bit, MapInfo Pro 15.2, MapInfo Pro v16.0. 

MapInfo Pro Basics - See your data in a Browser window

This article is suitable for any version of MapInfo Pro from v11.5 and onwards.

The Browser window is a tabular (row and column) view of your data.

Here is a partial screenshot of a Browser window.  In the 64 bit versions, the TABLE ribbon tab is the location for relevant commands and functionality.

 

User-added image
 

In the 32 bit versions, relevant Browser window functionality appears in both the Table menu and in a toolbar in the Browser window.  The following screen shot provides a functional overview of the Browser window. This is from the 32 bit interface.  The capabilities are available in both 32 and 64 bit versions.

User-added image

Right click on any column to sort or filter it.

Filtering Data in the Browser Window - Why is it important?

Filtering becomes very useful when you have a lot of data and you need to focus on some aspects of your data in particular.

Right clicking on any column gives you the option to sort or filter.

The Filter dialog box:

User-added image

It is possible to apply filters to multiple columns in your table. The Apply button allows you to see the results without closing the dialog box. You can make sure you have the filter the way you want it before clicking the Close button.

Note that a filter is not the same thing as a query. The filtering takes place within the existing Browser window and does not create a query for each filter operation performed. So...

Now that you've filtered your data, what's next?

If desired, a filter can easily be turned into a query. This allows you to use the filtered data as you would with any query. For example, a new separate Browser window can be displayed or the query can be added as a layer to a map window.

Here's how:

  • In the 32 bit versions, click the Sort and Filter menu on the Browser tool bar and choose Create a Query from the Browser Contents. (See the screen shot above.)
  • In the 64 bit versions, in the TABLE tab, click the Add to Map button. This is in the Sort and Filter group.


You will be given the option to name the query and view it in a map or a Browse

User-added image

A Browser window that has been sorted and/or filtered can be turned into a query.

Toggle your Browser Sorting on and Off

But wait, there's more. Let's say you have filtered and/or sorted the Browser window and you wish to restore it to its original condition. You can do this in two ways. One is to Clear the sorting or filtering. If you clear it then the settings are gone. A second method is to Toggle the sorting and filtering on and off.

 

To clear the filtering from a single column

All versions: Right click the column and choose 'Clear Filter'

To clear all sorting and filtering

(32 bit) Sort and Filter menu > Clear all Sorts and Filters Sort  
(64 bit) TABLE tab > Clear All

To temporarily turn  a filter off or on

(32 bit) Sort and Filter menu > Toggle Filter off/on
(64 bit) TABLE tab > Sort on/off

To clear sorting

(32 bit) Sort and Filter menu > Toggle Filter On
(64 bit) TABLE tab > Sort > Clear sort

Finally, for those editing data in a Browser window while a filter or sort has been applied can Reapply the sorting and filtering. There is a button on Browser window tool bar.

(32 bit) What if I want to get rid of the Browser window tool bar?

First, it is worth noting that the Browser window tool bars will not appear in the Layout window.

Easy Tip: Setting the default column display for a Browser window

Is there a way to show certain columns in a browser every time the table is browsed?

Yes!

If you are constantly removing unneeded columns from the display of the Browser window then this tip will be a time saver. It is possible to control which columns will display and the order they will be displayed in, as a default.

The Pick Fields command

The Pick Fields command allows you to control which columns are displayed in a Browser window.

  • 32 bit version: From the Browse menu click, Pick Fields
  • 64 bit version: In the TABLE tab, click Pick Fields

User-added image
Note the options to save the settings as your default Browser view.

Note that this capability is not making a permanent change to the structure of your table. The columns are hidden from view in the Browser window they are not permanently removed from the table.

Presenting Easting and Northings in a Browser Window

A  quick example of using the MapBasic window to sort out how to best present map coordinates from a UTM projected dataset.


The Challenge:
A table of data (Cadastre) that is projected onto a UTM map projection for Australia called MGA (Map Grid for Australia). I would like to make a quick report that shows a selection of records in a browser with their associated Easting and Northing values in each row.

User-added image

Easy enough right? Well, sort of. If I use the CentroidX(OBJ) and CentroidY(OBJ) functions to grab some coordinates of objects in the map I will be returned Longitude and Latitude - not Eastings and Northings.

The thing is that MGA is a map projection based on a geodetic datum called GDA94 (Geodetic Datum for Australia). GDA94 locations are represented in Longitude and Latitude: the spherical kind. But, I am looking for Easting and Northings: the flat-Earth kind.

If I create a Browser window of my selection and add X and Y for my polygon centroids I get the following;

User-added image

Note the CentroidX/CentroidY columns. Clearly this something only a rocket scientist can apply in the field. Mere mortals require something more workable when interpreting map locations. Eastings and Northings are great for getting a workable, flat, metric distance between objects.

The Solution:
Lets employ a simple Map Basic script command that will instruct MapInfo Pro to present the coordinates of the projection, as opposed to the geodetic datum.
  • Choose Options > Show MapBasic Window
  • Type the following in the MapBasic window: Set Coordsys Table Cadastre
Note: 'Cadastre' is the name of my table that has, funny enough, cadastral parcel objects. The table is projected to MGA(GDA94) Zone 56. Please read the MapBasic Reference Guide (available for free on our web site) if you would like to understand all the background to this command.


User-added image
  • In a map window containing the Cadastre layer I make a selection of objects from the layer
User-added image
  • Create a new Browser window of the selection
  • In the Pick Fields dialog box, add the following Expression fields using the Functions CentroidX(OBJ) and CentroidY(OBJ)
User-added image
  • You should have something like this. Choose OK
User-added image
You will now have Eastings and Northings in your browser instead of Longitude and Latitude. Great success!

To give a little polish to the result we will change the column heading names so they can be deciphered by those not of the MapInfo Scripting Samurai clan.
  • Go back into Browse > Pick Fields and select the CentroidX(OBJ) field on the right. In the edit box type in a friendly name for the column, like Eastings. Do the same for CentroidY(OBJ) and call it Northings. Choose OK.
 
User-added image

Done. You have now taken control of working with coordinates for data that may be stored against a coordinate system, yet projected onto specific map projection.

User-added image

User-added image


The Browser window in MapInfo Pro provides the option to display the rows in alternating colors. This helps to make the data easier to read. This option is turned on by default when MapInfo Pro is first installed. It is possible to turn this off or to change the secondary color being used.

For our example we will use a table of mocked up customer data.  (Notice anything funny about the names?) .


User-added image

Hypothetical customer data.

Alternating row preference

The alternating row color is controlled by a system preference. Select Options > Preferences > Browser Window.

 

User-added image

The Alternating Row Colors dialog box appears...

User-added image

If you choose a new color in this dialog box, the Browser window(s) will be changed right away. One important thing to note is that this setting controls all Browser windows. It is not possible to have different background colors for different Browser windows.

User-added image

The Browser window provides easy one click sorting but did you know that with just a few more clicks you can sort across multiple columns? For example it is possible to sort a table of customers by last name, then first name and then by their order amount.

The Browser window provides easy one click sorting but did you know that with just a few more clicks you can sort across multiple columns? For example it is possible to sort a table of customers by last name, then first name and then by their order amount.

Sorting on multiple columns
Another example is, given a table of cities in the USA first sort the cities by what State they are in and then sort by their population in descending order. Below is a screen shot of the data we will use.

The Sort/Filter menu
In the 32 bit version of MapInfo Pro the Browser window tool bar has a Sort / Filter menu as seen below. The first command is Sort Multi-Column...


User-added image

In the 64 bit versions of MapInfo Pro, the Table tab has a Sort and Filter Group. The Sort drop-down includes the Sort Multi Column... command.


User-added image

Below is the Sort dialog box. It is filled to sort the city table first by State and then by Total Population.

User-added image

You can sort up to five columns.
The following is the resulting Browser window.


User-added image

The cities are now sorted alphabetically by State and then in descending order by population within the state.

Save a workspace

If you wish to save and recall the Browser as it is sorted, just save a workspace.

Some quick Browser tips...
Quick Tip #1 : Triple click in a cell to select the whole contents!

Do you edit data in a Browser window? If yes, did you know that...
  • One click positions the mouse cursor in the cell you are clicking in.
  • Two clicks selects the whole word you are clicking on.
  • And three clicks selects the contents of the entire cell.

The above tip requires MapInfo Pro v11.0 or later.

Quick Tip #2: Short-cut to bring up a new Browser Window

If you are using a 32-bit version of MapInfo Pro, press F2 to bring up a new Browser window.
If you are using a 64-bit version of MapInfo Pro, press F4 to bring up a new Browser window.

Quick Tip #3: Use F8 to change the Text style of your Browser window

The F8 key is the shortcut to bring up the Text Style dialog box. When you are working with a Browser window, this has the effect of changing the text style of the Browser. This works in both the 32-bit and 64 bit versions of MapInfo Pro.

 
UPDATED:  July 22, 2019