VERIFIED SOLUTION i

Resolving issue where Bing patch fails to enable Bing Imagery in MapInfo Pro 32-bit

Product affected: MapInfo Pro™

Issue

Every year on Dec. 31 at midnight, Bing imagery within MapInfo Pro stops working for all versions except the current shipping version, due to a licensing agreement with Microsoft.
Engineering prepares a patch every year to resolve this issue for customers on maintenance for MapInfo Pro.

Recently Tech Support has seen issues where applying the Bing patch did NOT resolve the loss of Bing imagery as expected.

Cause

1) Tech Support has seen this issue occur when a "Bing license Key" has been incorrectly entered, which will cause Bing to stop working.

The Bing Key credentials should typically be blank:
User-added image

2) If #1 is not the problem, another cause is most likely due to the serial number and access code being out of sync at two places within the Registry.

Sometimes, an "Eval" serial number is found in one of the registry entries. If that is found, the EVAL credentials need to be edited and replaced with the valid serial number and access code found in the other registry entry.


An "Eval" serial number and access code would look similar to:

MIEWEU1500000000-000000

The presence of all "zeros" indicates an Eval serial which needs to be edited and replaced with a valid number.

 

Resolution

UPDATED: June 18, 2019
Try the following steps to resolve the issue.

1) Clearing an incorrect Bing Key will resolve the issue if that is the cause.

In MapInfo Pro, first check to make sure there is nothing entered in the Bing License Credential dialog.
32-bit versions:  Help>licensing>enter a Bing license key.
64-bit versions:  Pro>licensing>Bing License Key

That dialog should be blank.
If it is not blank, delete any entry there.
Then test and re-run the Bing patch if it is still not working.


2) To check and correct the serial number/access codes, follow the process below:
(An IT Administrator may have to perform this if access to the Registry is denied due to permission issues)

- Go to start>search>type "Regedit" and click Enter
- Go to this registry key for 32-bit versions such as 15.0:

HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\MapInfo\MapInfo\Professional\1500
- On the right side, take note of the values for ProductID and AccessCode
- Check to see that it is NOT an Eval serial number/access code as described earlier.
- For 64-bit versions of MapInfo Pro, such as v17, check and proceed with the steps previously outlined:
HKEY_LOCAL_MACHINE\SOFTWARE\MapInfo\MapInfo\Professional\1700

If it is not an Eval, then note the values.

- Then go to this registry key using v15 for the example:
HKEY_CURRENT_USER\Software\MapInfo\MapInfo\Professional\1500
- For 64-bit versions, this general path is the same except for the last number which would be ...\1700 for v17 as an example.

- On the right side, take note of the values for ProductID and AccessCode
- Check to see that it is NOT an Eval serial number/access code as described earlier.

If it is not an Eval, then note the values.


- Once the ProductID and AccessCode is compared in both locations, edit one to match the Valid ProductID and AccessCode replacing any Eval-type ProductID and AccessCode that would have all Zeros in the numbers.

After making sure both locations have the same, valid ProductID and AccessCode (serial number and access code), Re-Run the current Bing patch and test.