"Invalid Account Number" message on the DM50-DM60

Products affected: DM50™, DM55™, DM60™ (K721, K722)
 

Issue

"Invalid Account Number" message displays when installing or refilling your franking machine.

Cause

You may have an issue with your Pitney Bowes account.

 

Resolution

UPDATED: 30 April 2020
You may need to resolve an issue with your Pitney Bowes account if "Invalid Account Number" displays when you install or refill your franking machine.

Use the Contact Us options below to contact Technical Support for further assistance.