"Cover Open" message on DM50-DM60 Series, DM100i-DM475, Connect + Series and SendPro P

Products affected: DM50™, DM55™ (K721), DM60™ (K722), DM100™, DM150™, DM200™ (P720), DM110i™, DM160i™, DM220i™ (PR20), DM300c™, DM400c™, DM475™ (G920), DM300M™, DM400M™, DM475M™ (G922), Connect+ ® / SendPro ® P

Issue

Cover Open message displays on your meter.

Cause

Either a cover is open or a switch or sensor may be malfunctioning.

Resolution

UPDATED: 19 December 2019
Please start by ensuring all the covers are correctly closed and no debris is blocking the covers.

If you are still seeing the "cover open" message when the covers are correctly closed please follow the steps below:
  1. Power down your meter via the screen options or by removing the power cable. When removing the power cable, ensure the meter is not connecting or updating. This will be advised on the screen.
  2. Open and close all covers ensuring there is nothing stopping the covers from closing correctly.
  3. Replace the power cable (if required) and turn on your meter
If the issue is unresolved please use the Contact Us options below.