Resolving the Unknown Rate Manager error on the SendPro C Lite, SendPro C, SendPro+, SendPro C Auto

If meter displays "Unknown Rate Manager Error", follow these steps to reboot it.

Products affected: SendPro® C Lite, SendPro® C, SendPro®+, SendPro® C Auto  (2H00, 8H00, 9H00)

Issue

The device displays "Unknown Rate Manager Error"

Cause

The device does not recognize the rate files

Resolution

You may be able to clear the error by simply restarting your device. Here are the steps to follow for a safe restart:

  1. Unplug the power cable. The screen should turn off after 10 seconds.
  2. Wait 30 seconds.
  3. Plug the power cord directly back into a wall outlet. Check that the wall outlet is working correctly.
  4. Quickly tap and release the power button to turn the device back on.

If you need further assistance, please contact us.

UPDATED: April 22, 2022