Resolving the error "Your subscription does not have any valid features. Please contact MapInfo Technical Support" during MapInfo Pro and Viewer logging

Affected products: MapInfo Viewer, MapInfo Pro
 

Issue

The user receives the error message "Your subscription does not have any valid features. Please contact MapInfo Technical Support" when logging to the MapInfo Viewer or to MapInfo Pro web services.

User-added image

Cause

The end-user had signed up for the Knowledge Communities and had a Pitney Bowes account.
He then logged into MapInfo Pro with those credentials, however, because he didn't go through the sign-up process in MapInfo Pro there was no "MapInfo" subscription added to his account.

Resolution

UPDATED: April 15, 2020
Please go through the Sign Up dialog in MapInfo Pro. This sign-up dialog can be accessed via PRO > Services > Sign Up Now in MapInfo Pro

When you enter your Email into the Signup dialog there is an ADD SUBSCRIPTION FLOW in place that will recognise that you have a Pitney Bowes account and will ask you if you want to add a MapInfo subscription to your account.