Problem after upgrading Spectrum Spatial Analyst 2018.2 to 2019.1

Issue

After upgrading SSA 2018.2 to 2019.1 it is failing to log into Spatial Analyst for any users with the following error:

HTTP ERROR 401

Problem accessing /rest/Spatial/ProjectService/projects.json. Reason:

    Unauthorized

The install log

Looking at spatial repository the user see no resources for any users or roles.

Looking at the install log file we see:
Additional Notes: WARNING - There was a problem copying /opt/ssa2019/analyst/customerconfigurations

Cause

When running an upgrade of SSA from 2018.2 to 2019.1 if a new destination install folder is chosen, then the installer runs the migration utility from the destination, not the source. For example, the original ssa was in the folder /opt/ssa2018 and the new destination was /opt/ssa2019. The migration utility was run against /opt/ssa2019 when it should have run against /opt/ssa2018.

Resolution

UPDATED: April 1, 2020
Rerun the migration utility with the correct source. In this example:
sudo /opt/ssa2019/analyst/migration/analyst_resource_migrator.sh -url=http://platform.spectrumspatial.com:8181/ -username=admin -password=***
-dirInput=/opt/ssa2018/analyst/customerconfigurations -javaPath=/usr/java/jdk1.8.0_201-amd64