Resolve ",hexadecimal value 0x1D, is an invalid character when processing a package in SendSuite Xpress

Learn how to resolve the error message " ",hexadecimal value 0x1D, is an invalid character. Line #, position #..." when processing a package in SendSuite Xpress.
Products affected: SendSuite® Xpress

Issue

After importing and running a batchlink file in the main Shipping Screen, when processing a package, the following error is displayed before obtaining a weight:
 
", hexadecimal value 0x1d, is an invalid character. Line #, position #...

Cause

There are invalid hexadecimal values in the import file for batchlink.

Resolution

To resolve this issue:
  1. Download and install Notepad++ (free).
  2. Navigate to the import file used for batchlink. Right-click on the file and select Edit with Notepad++.
  3. Look for any letters that appear in a black box. Example:
    • GS example
    • These are character sets for ASCII code and each has its own meaning. (For more information, see this list.) These characters have to be removed before the list will import and run successfully.
  4. To remove these characters:
    1. From the top menu in Notepad++, select Search > Replace.
    2. In the Find what box, type the hexadecimal code for the Character set.
      • In the Find what box type: \x
      • From the list referenced in step 3, find the Hex code associated with the Char that appears in the list.
      • Example: The GS Hex code is 1D, so in the Find what box you would type \x1d
    3. Leave the Replace with box blank.
    4. In the Search Mode box in the lower left, select Regular Expression.
    5. To finalize removing the code, select the Replace All button on the right side.
    6. Repeat until all codes are removed.
  5. Once all extra codes are removed, go to File > Save to save your list.
  6. Re-import your batchlink file and test.
If the issue persists, contact software support.

UPDATED: September 26, 2022