Resolve Verimove 3.7 install error "version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6)"

Products Affected: VeriMove 
Operating System: Linux; Unix, RedHat


 

Issue

Running ./muver results in the following error after Verimove upgrade to 3.7:

vl1528rtp1:/feofddapp1/app/verimove/nlk > ./muver 
./muver: /feofddapp1/app/verimove/nlk/lib/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6) 
 

Cause

This error indicates the standard C++ libraries for Unix/Linux machines cannot be found.

Resolution

UPDATED: October 5, 2017
To download and install the missing libraries, use this link:

https://gcc.gnu.org/install/download.html

In addition, ensure that the gcc libs are towards the beginning of the path and the LD_LIBRARY_PATH is set correctly.  The command ‘echo $LD_LIBRARY_PATH’  will show the path statement.  If the gcc libs are not in the path, they can be added: 
  • LD_LIBRARY_PATH=/lib:/usr/lib:.:/$LD_LIBRARY_PATH