VERIFIED SOLUTION i

Resolve error in MapInfo Pro when accessing any Projection dialog - (sic) "MapInfo 4.50 or greater needed...."

Products affected: MapInfo Pro™
 

Issue

User running any version of Pro tries to activate any Projection dialog (map>options>projection or hitting the projection button when saving  a file, etc.)
an error is thrown stating that MapInfo Pro version 4.50 or greater is required....

Cause

The typical cause of this error is that the MapInfow.exe has become unregistered...
This error usually occurs when there is more than on version of Pro installed on a machine.

Resolution

UPDATED: September 19, 2017
To resolve , close MapInfo Pro and open up a DOS window with Admin Rights, then navigate to the Professional folder for the version of Pro that throws the error and type:

mapinfow.exe /regserver

and hit enter.