Resolve stuck on "Initializing" on the DM100i-DM225

Products affected: DM100®i, DM125™, DM200L™, DM225™

Issue

The meter will not progress past the "Initializing" screen.

Cause

The meter has experienced an internal error that is preventing normal operation.

Resolution

UPDATED: July 25, 2019
To resolve this issue, restart the meter:
  1. Unplug the power cord.
  2. Wait one to three minutes.
  3. Plug the power cord back in, ensuring that it is plugged directly into a wall outlet.
Use the Contact Us options below if you need further assistance. Have your model and serial number ready.