"Low Sector" message on the DM100i-DM225 and SendPro 300

Products affected: DM100®i, DM125™, DM200L™, DM225™, SendPro® 300

Issue

Your meter displays the message "Low Sector" and does not turn on.

Cause

An internal component failed.

Resolution

UPDATED: July 23, 2019
Restarting your meter may resolve this error.

Follow these steps to restart your meter safely:
  1. Unplug your power cord.
  2. Wait one to three minutes.
  3. Plug your power cord back in, ensuring that it is plugged directly into a wall outlet.

Use the Contact Us options below, if you need further assistance. Have your model number and serial number ready.