VERIFIED SOLUTION i

Troubleshooting connection issues with PC Meter Connect

Products affected:
DM50
, DM55 (K721)
DM60
(K722)
DM100
, DM150, DM200 (P720)
DM110i
, DM160i, DM220i (PR20)
DM300c
, DM400c, DM475 (G920)
DM300M
, DM400M, DM475M (G922)

Issue

The meter is unable to add funds, upload data, or perform software or rate updates while connected using the PC Meter Connect™ software.

Cause

The meter cannot communicate with PC Meter Connect, or PC Meter Connect cannot connect to the Pitney Bowes Data Centre. This could often be caused by an update to the PC the meter is connected to.

Resolution

UPDATED: 19 August 2019
Follow these steps in order to troubleshoot and resolve your PC Meter Connect issues:
  1. Verify that PC Meter Connect is installed on the computer
  2. DM300, DM400, DM475 only - Connection Mode: Auto
  3. No Dial Tone / No Carrier Detected / Modem Not Detected
  4. Restart the PCMC program
  5. Meter Not Detected
  6. DE00 or EDE00
  7. Reinstall PC Meter Connect
 

1. Verify that PC Meter Connect is installed on the computer

To verify that the computer you have plugged the meter into has the PC Meter Connect (PCMC) software installed, click the Start button and type "PC Meter Connect". If you find no results, see "How to install PC Meter Connect" for further instructions.

 

2. DM300, DM400 and DM475 (G920 and G922) only
  1. Press the Options key.
  2. Press Page Down twice.
  3. Select Data Center Options.
  4. Press Page Down.
  5. The third option is Connection Mode: ...:
    1. If the meter displays Connection Mode: Phone, press the corresponding button on the left. The meter will return to the Data Center Options page. Press Page Down, the meter should now display Connection Mode: Auto.
    2. When the meter displays Connection Mode: Auto, press the Home button to return to the Home page.
 

3. No Dial Tone / No Carrier Detected / Modem Not Detected

These error messages on your meter mean that the meter has not recognised that it is connected to the computer (and vice versa).
  1. Ensure that the telephone line is removed from the back of the meter.
  2. Ensure that the square end of the USB cable is plugged into the back of the meter, and the flat end into an active USB port on your computer.
  3. Clear the error on the meter, or restart if the error cannot be cleared.
  4. Follow the steps below to relaunch the PCMC program.
 

Exit and then restart the PC Meter Connect program:

The PC Meter Connect program runs in the background on your computer. If it is left running for a long period of time, the program can become unresponsive when the meter is connected. A simple relaunch of the application can often resolve this issue.
  1. Check if the PC Meter Connect program is running:
    1. either double-click the  icon on your Desktop
    2. or press the Start button and type "PC Meter Connect"
  2. If you see a message saying "PC Meter Connect Already Running", press OK.
  3. You can find the PCMC icon in the bottom right-hand corner of the computer, near the clock. It is often hidden, click the up triangle on the taskbar.
    1. When a meter is connected, the icon is an orange arrow.
    2. When meter is not connected, the icon is a red cross. When you hover the mouse cursor over the icon it says "Meter not detected by PC" or "Internet Not Detected".
  4. Exit the program by right-clicking the icon and left-clicking Exit.
close the PC Meter Connect program
  1. Reopen the program (from the desktop icon, or via Start and search "PC Meter Connect").
  2. Plug the flat end of the USB cable into a USB port on the computer, then plug the square end into the back of the Meter.
  3. The computer should immediately show a pop-up box, saying "Meter detected". This means the meter has been recognised, and you can proceed with attempting a connection on the meter.
PC Meter Connect - Meter Detected
 

PC displays a pop-up: "Meter not detected" or "Internet Not Detected"

When the meter is not connected to the computer, these messages can be ignored.

If these messages display when the meter is connected, and are not shortly replaced by "Meter Detected" - and you have already followed the steps above to relaunch the PCMC program - attempt the steps below:
  1. Ensure that the meter is fully booted up.
  2. Ensure that the USB cable's flat end is plugged into the computer, the square end into the meter.
  3. Try connecting the USB cable to a different USB port on your computer.
  4. Try a different USB cable.
 

Error codes

If the computer is recognising the meter, but the meter displays an error code DE00 or EDE00, first restart the PCMC program.

If the error persists, try adjusting the "Internet Settings":
  1. Right-click on the PCMC icon from the taskbar.
  2. Left-click "Internet Settings...":
 PC Meter Connect Internet Settings UK
  • For Mailmark™ meters (meter models K722, PR20 and G922) the "Protocol" should be set to "HTTP Mode".
  • There is no right or wrong combination of these settings - try altering the settings until you find a combination that works for you.
  • If your meter uses a Proxy, depending on your requirements select either "Use Internet Explorer" or "Manual proxy settings". Speak to your IT department if you require assistance with proxy settings.  
 

Uninstall and reinstall the PCMC program
  1. On your computer, press Start and type "PC Meter Connect".
  2. Select "Uninstall PC Meter Connect" and follow the on-screen prompts to uninstall the software.
  3. See How to install PC Meter Connect for the download link and instructions on re-installing the program.