Resolve "error getting DateSigned for NCOA Customer ## - Invalid cursor state" in Verimove

Operating System: Windows
 

Issue

Upgraded to Verimove 3.5.5 and executing an existing job, encountering - Error getting DateSigned for NCOA Customer ##.  Invalid cursor state

Cause

During upgrade, all customer entered information in the Customers, Operator IDs and Broker/Agent/List Admin tab has been removed.  

Defined jobs no longer have a Customer ID or Operator ID assigned in the General tab of the job.
 

Resolution

UPDATED: April 21, 2017
If a backup of the Database folder was done before upgrade, copy and paste the ForwardTrakStatistics.* files into the Database folder for install of Verimove 3.5.5.

If a backup of the Database folder was not done, manual entry of Customers, Operator ID and Broker/Agent/List Admin information or importing of job definition file containing the Customer, Operator and Broker/Agent/List Admin information is the first step of resolution.

Manual entry via Verimove GUI:
1)  Select 'Tools'
2)  Select 'Options'
3)  Select 'NCOALink'
4)  Select Customers tab, click 'Add'
5)  Enter information.

NOTE:  To enter information for Operator IDs or Broker/Agent/List Admin, use the same steps of steps 1 to 3 as stated above.  Click on Operator ID tab or Broker/Agent/List Admin tab and click on 'Add'.

To import a job definition file:
1)  Select 'Job'
2)  Select 'Import'
3)  Navigate to the .def file to import and select file
4)  click 'Open'
5)  click 'OK'

Edit job via the Verimove GUI to assign Customer ID and Operator ID fields:
1)  highlight job
2)  right click and select 'Edit'
3)  In the 'General' tab navigate to the Customer ID: field and click on 'Select'
4)  Highlight NCOA Customer and click 'OK'

NOTE:  Same steps for the Operator ID field.