VERIFIED SOLUTION i

How to resolve no print head detected on the DM100i and DM125

Products affected: DM100®i and DM125™

Issue

The message no print head detected is on the display and no postage can be printed.

Cause

The print head is missing or may be faulty.

Resolution

UPDATED: January 11, 2016
Check the print head for bent pins:
  1. Open the top cover
  2. Lift up and remove your ink cartridge
  3. Squeeze the two gray tabs on either side of your print head. While squeezing, lift and tilt to the right. Your print head should easily lift out of your machine.
  4. Check for bent pins on the meter wall
Note: If pins are bent, contact customer support from 8 am to 8 pm Eastern Time. Have your model number ready
  1. If the pins are not bent, place print head and ink cartridge back in meter
  2. Close the ink latch latch and top cover

You may be able to clear the error by simply restarting your meter. Here are the steps to follow for a safe restart:
  1. Unplug the power cord; wait one minute
  2. Plug the power cord back in, ensuring that it is plugged directly into a wall outlet
If your issue is not resolved, contact customer support from 8 am to 8 pm Eastern Time. Have your model number ready.