VERIFIED SOLUTION i

How to resolve Data access driver requested is not available: ORAINET. Unable to open table error in MapInfo Professional

Products affected: MapInfo Professional ®

Issue

When trying to open a table linked to Oracle, in MapInfo Professional ®, the following error is encountered:

Data access driver requested is not available: ORAINET. Unable to open table <Tablename>.

This will also appear in Workspace Error Log window if you are trying to access a Workspace.

When trying to make a new DBMS connection then Oracle is not in the list of possible connection types.

 

Cause

This is due to MapInfo Professional either:
  • being unable to detect a 32 bit version of the Oracle client
  • the version of Oracle that you are trying to connect to is not supported by that version of MapInfo Professional

Resolution

UPDATED: March 27, 2018
Check that the version of Oracle that you're trying to connect to is compatible with the version of MapInfo Professional that you're using. If it compatible then check to see if you have the 32 bit version of the Oracle client installed.