VERIFIED SOLUTION i

Resolving “Initialization error: unable to load the CLR (-2146232062)” in MapInfo Pro

Products affected: MapInfo Pro™

Issue

During the installation of MapInfo Pro, users may receive the error
'Initialization error: unable to load the CLR (-2146232062)'.

This error can also occur after running the setup.exe file by right-clicking and choosing the Run as Administrator option and uninstalling and reinstalling .NET Framework.

"CLR" errors typically involve an issue with the .NET, one of the pre-requisite programs for MapInfo Pro.

Cause

This error may occur when .NET Framework can only be installed by a domain administrator with sufficient Rights and not a typical "user".

Resolution

UPDATED: June 24, 2019
Users should allow their Network Administator (i.e."IT" rep.)  to log onto the machine with their Local Machine Admin credentials and uninstall and reinstall both .NET Framework and MapInfo Pro.
Note: For Windows 10, the .NET components are part of the OS and cannot be easily installed/uninstalled.