Resolve "Dispense Postage failed: (2418) Invalid Destination Zip for the given address" when shipping with PON carrier in SendSuite Xpress

Products affected: SendSuite® Xpress

Issue

When shipping a package in SendSuite® Xpress with the PON carrier, after selecting Record, the error message "Dispense Postage failed: (2418) Invalid Destination Zip for the given address..." is displayed.

Cause

An invalid ZIP code was entered for the destination address.

Resolution

UPDATED: March 20, 2017
To validate the address and correct the error:
  1. Go to the USPS ZIP Code lookup website.
  2. Enter the address that caused the error.
  3. Select the Find button.
  4. It will indicate whether the address could be verified, and will provide the full address using standard abbreviations and formatting.
  5. Enter the address information from the website into your shipping screen and try to record the package again.
If this does not resolve the issue, contact client support.