Resolve Error "You need to have MapInfo Professional or Runtime v9.5 or later installed first" when installing Vertical Mapper 3.7 on a MapInfo Professional 16 environment.

Product affected: Vertical Mapper 3.7.1, MapInfo Pro

Issue

When only a MapInfo Pro 16 (64 bit) is installed and user tries to install the add-on product Vertical Mapper Version 3.7 (VM), an error is thrown incorrectly indicating that the user's version of MapInfo Pro is insufficient to run Vertical Mapper and the install halts. See image of error below.
User-added image

Cause

The vertical mapper installer checks the user's registry to determine what version(s) of MapInfo Pro are present, using the "ProgramDirectory" key found at 
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\MapInfo\MapInfo\Professional\<Version Number>

When an environment only has a 64 bit version of MiPro, the above 32 bit registry key would not be present and as a result the installation of the software fails.

Due to the fact that Vertical Mapper is only a 32 bit application, it can only be installed when a 32 bit version of MapInfo is installed on the host machine.

Resolution

UPDATED: October 25, 2017
To resolve:

1. Upgrade to MapInfo Professional Advanced version, which is the replacement product for Vertical Mapper.
2. Install a 32 bit version of MapInfo Professional or Runtime then run the application with elevated user rights.