"Print driver host for 32bit applications has stopped working" or "Print driver host for applications has stopped working" in the SendPro desktop app for Windows

Products affected: SendPro® Desktop Application for Windows

Issue

When using the SendPro Desktop Application for Windows, the message "Print driver host for 32bit applications has stopped working" or "Print driver host for applications has stopped working" is displayed.

Cause

The SendPro Desktop Application for Windows has a conflict with a Windows HP universal printer driver.

Resolution

UPDATED: November 25, 2020

Windows 7

  1. Click on Windows Start.
  2. Click Devices and Printers.
  3. Right-click on the HP printer you are using with SendPro.
  4. Click Printer Properties.
  5. Click the Advanced tab.
  6. Click New Driver.
  7. Click Next.
  8. Choose HP as the Manufacturer.
  9. Select the printer name HP Universal Printing PS.
  10. If this printer name is not listed, see the section Install a new HP printer driver below.
  11. Click Next.
  12. Click Finish.
  13. Click Ok.
  14. Restart the SendPro Desktop Application.

Windows 10

  1. In Windows search, type Control Panel.
  2. Open Control Panel.
  3. Click Devices and Printers.
  4. Right-click on the HP printer you are using with SendPro.
  5. Click Printer Properties.
  6. Click the Advanced tab.
  7. Click New Driver.
  8. Click Next.
  9. Choose HP as the Manufacturer.
  10. Select the printer name HP Universal Printing PS.
  11. If this printer name is not listed, see the section Installing a new HP printer driver below.
  12. Click Next.
  13. Click Finish.
  14. Click Ok.
  15. Restart the SendPro Desktop Application.

Installing a new HP printer driver

  1. Disconnect the HP printer's USB cable.
  2. Go to the HP Universal Print Driver download page.
  3. Select your version of Windows and click Change.
  4. Select the + symbol next to Driver-Universal Print Driver.
  5. Select the Download button for HP Universal Print Driver for Windows PostScript.
  6. Go to your Downloads folder and double-click on the downloaded file to run it.
  7. In the WinZip Self-Extractor wizard window, select Unzip. The Setup Wizard starts.
  8. Select Yes to the License Agreement.
  9. Select USB mode - Plug and Play.
  10. Leave both boxes checked under USB mode - Plug and Play.
  11. Select Next.
  12. When prompted to plug the USB cable into the printer, plug it in, then select Finish.
  13. Restart the SendPro Desktop Application.