VERIFIED SOLUTION i

Resolve "Remote library could not be initialized" in ConnectRight Mailer

Products affected: ConnectRight™ Mailer

Issue

When attempting to install or use ConnectRight™ Mailer, the error “Remote library could not be initialized” is displayed.

Cause

This error suggests that you are unable to connect to the ConnectRight Mailer servers to obtain the library files needed by ConnectRight Mailer. This may be due to:
  • A firewall refusing the connection to the ConnectRight Mailer servers
  • A proxy server refusing the connection to the ConnectRight Mailer servers

Resolution

UPDATED: June 16, 2017
Allow connections to the following IP addresses in your firewall(s). If you have a proxy server in your network, allow connections to these IP addresses in your proxy server:
  • 50.205.20.74
  • 64.131.53.165
  • 64.131.53.174
If you are not sure if you have a proxy server in your network:
  1. Select the Windows Start > Control Panel.
  2. Ensure View by (in upper right corner of the Control Panel window) is set to Large icons or Small icons.
  3. Select Internet Options.
  4. In the Internet Properties dialog box, select the Connections tab.
  5. Select LAN settings.
  6. If Use a proxy server for your LAN is checked, then you are using a proxy server.
If the error still appears after allowing the connections in all firewalls and proxy servers, contact software support.