MapInfo Pro 64-bit and error editing Excel Data: "The Microsoft ADO Engine is not available for error information" due to missing 64-bit Access driver

Products affected: MapInfo Pro™
 

Issue

MapInfo Pro 64-bit version generates an error when opening Excel data or running a custom .mbx that updates Excel Data:
"The Microsoft ADO Engine is not available for error information".

 

Cause

If a user has a 32-bit version of Microsoft Office, then the MapInfo Pro installer cannot install the needed
64-bit Access driver, due to Microsoft policy.
 

Resolution

UPDATED: December 2, 2019

64-bit vs 32-bit MS Access drivers
MapInfo Pro is a 64-bit application that can read spreadsheets and tables from Microsoft Excel and
Access. To do so you require the Microsoft Access database engine (x64). If you do not have this software
installed, the installer will prompt you if you would like it installed. However, if you already have the 32-bit
version (for example, installed as part of Microsoft Office) the MapInfo Pro installer will not be able to
install the 64-bit version of the database engine. One option is to uninstall the 32-bit Microsoft Access
database engine (for example, by uninstalling Microsoft Office) prior to installing MapInfo Pro 64-bit. This
is the recommended approach by Microsoft. If you require both versions of the Microsoft Office drivers
on the same system with MapInfo Pro, then follow the procedure below. It is recommended to put both
the 32-bit and 64-bit drivers on the same machine.
Installing 32- and 64-bit MS Office Drivers
MapInfo Pro is a 64-bit application that can access spreadsheets and tables from Microsoft Excel and
Access. To use data from Excel and Access within 64-bit MapInfo Pro, the Microsoft Office
64-bit driver must be used.
As part of the MapInfo Pro installation process, the 64-bit Microsoft Access Database Engine 2010
Redistributable for Office is installed if the Microsoft Access Database Engine 2010 32-bit driver is not
already installed on the system. The effect of this is, if 32-bit Microsoft Office is already installed on the
system, the MapInfo Pro installation process will not install the 64-bit Access Database Engine drivers
necessary for 64-bit MapInfo Pro access to Excel and Access.
If the 32-bit edition of Microsoft Office or its driver on the same system with 64-bit MapInfo
Pro, the following procedure shows how to install both versions of Office drivers.
Microsoft does not support both drivers installed on the same computer citing incompatibility
between the product editions or their components. See http://support.microsoft.com/kb/2269468
for more details.

To install MS Office 32- and 64-bit drivers on the same system follow the procedure described below.
In order to perform this action, you need to have administrative rights to install or uninstall the software
on your computer. If not sure of the proper permissions, then contact an IT system administrator
for support before proceeding.
1. Download the MS Office drivers from
http://www.microsoft.com/en-ca/download/details.aspx?id=13255.
The 32-bit version is AccessDatabaseEngine.exe. The 64-bit version is
AccessDatabaseEngine_x64.exe.
2. Determine if the MS Office 2010 64-bit Office driver installed. It may already be
installed if MapInfo Pro 64-bit was installed. To determine if the MS Office 2010 64-bit
driver is installed, open Windows Explorer and navigate to the folder C:\Program Files\Common
Files\microsoft shared\OFFICE14. If you have a file called ACEOLEDB.DLL installed, then
you have the 64-bit driver installed. If you have the file ACEOLEDB.DLL installed in C:\Program
Files (x86)\Common Files\microsoft shared\OFFICE14, then you have the 32-bit driver
installed.
The 32-bit driver is automatically installed if a 32-bit MS Office 2010 has been installed.
If the 64-bit driver installed, uninstall this driver, reboot the system, and proceed to
step 3. If the 32-bit driver is installed go directly to step 4.
Note:
3. Install the 32-bit Office 2010 driver.
4. In the System folder (for example C:\Windows\System32), right-click on cmd.exe and select Run
as administrator.
5. At the command prompt navigate to the folder where the 64-bit Office 2010 driver is located. For
example, if the AccessDatabaseEngine_x64.exe is downloaded and place it into the C:\temp
folder, then type cd C:\Temp in the command prompt, and hit the Enter key.
6. Type the command AccessDatabaseEngine_x64.exe /passive and and hit the Enter key.
7. If 32-bit Microsoft Office 2007, 2010 or 2013 is installed on the system, open the registry
editor (in the command prompt, type: regedit and hit the Enter key.) then check
the key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\14.0\Common\FilesPaths.
If there is a registry value called mso.dll, then delete or rename it. If you 
the mso.dll registry value is not deleted or renamed, a Reconfiguring message will be displayed every time Excel or Access is opened up directly in an Office application.
Both drivers are now installed on the system..