"The password you provided was not recognized. Please try again." in SendPro Online

If you get the message "The password you provided was not recognized. Please try again.", try changing your password.
Products affected: Connect+® 500W, Connect+® 1000, Connect+® 2000, Connect+® 3000, SendPro® P1000, SendPro® P1500, SendPro® P2000, SendPro® P3000, SendPro® Online

Issue

When signing in to SendPro Online, the message "The password you provided was not recognized. Please try again." appears.

Cause

The password being used is not valid.

Resolution

Try changing your SendPro Online password.

Related topics

UPDATED: July 31, 2023