Resolve "The date format set by Windows (M/d/yy) is not accepted by Business Manager. See the LOG file for more information." when opening Business Manager

Products affected: Business Manager

Issue

When trying to open Business Manager, the error "The date format set by Windows (M/d/yy) is not accepted by Business Manager. See the LOG file for more information." is displayed.

Cause

Business Manager can only open with Regional short date in the MM/dd/yyyy format.

Resolution

UPDATED: August 31, 2017
To resolve this issue:
  1. Select Start Control Panel, Clock, Language, and Region > Region and Language.
  2. Select the Formats tab.
  3. Select Short date to MM/dd/yyyy.
  4. Select OK.
If this does not resolve the issue, contact software support.