"It's not you, it's us. We're having an internal server issue." message in SendPro Online

Learn how to resolve the message "It's not you, it's us. We're having an internal server issue."
Products affected: SendPro® Online, SendPro® Online software

Issue

When trying to sign in to or use SendPro Online, the message "It's not you, it's us. We're having an internal server issue. We're working on fixing it. In the meantime you can try reloading the page." appears.

Cause

  • Your browser may have a cache problem.
  • You may be using an outdated bookmark/link.
  • There may be a conflict with the Office 365 integration feature.
  • Your service may be suspended.
  • There may be a server problem.
  • Your OMAS profile may be not configured properly (OMAS/Schedule 48 Government Agency clients only).

Resolution

Solution 1: Clear your browser cache (SendPro Online software only)

If you are using the SendPro Online software, see Clearing the cache for instructions.

Solution 2: Check for an outdated bookmark or link

You may be using an outdated bookmark or link. Make sure that the address you are using is http://sendpro.pitneybowes.com/.

Solution 3: Disable Office 365 integration

  1. Select Settings > Preferences.
  2. Select the Revoke Access link next to Office 365.

UPDATED: October 12, 2023