Does Spectrum 9 require 32-bit Java 7

Spectrum 9 requires both 64bit and 32bit Java 7.
UPDATED:  March 28, 2017