VERIFIED SOLUTION i

"Can not find File MIInstallUtil.dll" error when installing MapInfo Pro

Products affected: MapInfo Pro™
 

Issue

The error shown below can occur when installing MapInfo Pro via the installation wizard.
"Can not find File MIInstallUtil.dll"


User-added image

Cause

The install process is looking for the registry key named 'ProgramDirectory' located under HKLM\Software\MapInfo\MapInfo\Professional\version\ and is either not finding the key or the key is returning a null string (that is, it is returning “” instead of a file path such as C:\Program Files\MapInfo\Professional, etc.).

By running the installer again on this workstation and checking the registry key listed above after the error message is shown, it can be determined which of the two situations has occurred.
Most likely it is the first instance where the registry key is missing.

The installer at one point runs the command: <path to mapinfow.exe>\mapinfow.exe – regserver
(that is, for a default install it would be: "C:\Program Files\MapInfo\Professional\ mapinfopro.exe – regserver" for 64-bit versions or "C:\Program Files (x86)\MapInfo\Professional\mapinfow.exe - regserver" for 32-bit versions) 
If this command fails to run,  an error message is displayed:  
“Failed to run C:\Program Files\MapInfo\Professional\ mapinfopro.exe – regserver”
or
"Failed to run C:\Program Files (x86)\Professional\mapinfow.exe - regserver".

If the message did not display, this would imply that the command had run but the installation did not have permissions to add needed keys to the registry using this method.

The most likely reason for this lack of permissions would be that the IT department may have pushed some policies on the computer that has limited a user's permissions on the computer where the user is trying to install MapInfo Professional.
(note: network polices always override local policies).

However, there may be other reasons why the command is not being allowed to alter the registry and users will have to work with their IT department to figure out why this is occurring. 

Resolution

UPDATED: October 4, 2019

Users can add the missing registry entries by opening a command prompt (by first right-clicking on the command line shortcut cmd.exe and select “Run as administrator”), and then type the command: “<path to mapinfow.exe>\mapinfow.exe” – regserver.
Once the command has finished running, allow the installer to complete and then try to start up MapInfo Pro to see if it works.


It is also worth checking if 'Microsoft .NET Framework v3.5' is enabled under Control Panel > Programs and Features > Turn Windows features on or off
Enable it if it is not enabled, and click yes if a prompt appears asking to download an update to enable it. Click on OK to confirm and exit the Windows Features dialog box.

*Note - This issue is almost always related to insufficient Rights for the person installing the software.
Users installing must have local machine administrator rights. The actual running of MapInfo Pro typically only requires Power User-level rights.