Product affected: MapInfo Pro™
Issue
"Unable to validate your license due to error 880057" error appears when launching MapInfo Professional.
From the Flexnet Guide, the error code means:
Error 880057: "//Access has been denied to a resource, either a service or a file, or the registry while installing/uninstalling of Flexnet Licensing Service. Administrator privilege is required to resolve this problem".
From the Flexnet Guide, the error code means:
Error 880057: "//Access has been denied to a resource, either a service or a file, or the registry while installing/uninstalling of Flexnet Licensing Service. Administrator privilege is required to resolve this problem".
Cause
This may occur if MapInfo Professional was not installed with sufficient privileges.
Typically, insufficient Rights of the user running the installation prevent the Flexnet Services (needed for licensing) from installing/starting.
Typically, insufficient Rights of the user running the installation prevent the Flexnet Services (needed for licensing) from installing/starting.
Resolution
UPDATED: December 2, 2019Go to Start > Programs > MapInfo Pro and Right-Click on the MapInfo Pro shortcut and select Run as Administrator.
If Pro throws the error, go to Control Panel > Admin Tools > Services
and make sure the FLEXNET services are installed, started and set to "automatic".
It may be helpful to have an IT rep. log on as the Local Machine Admin and test MapInfo Pro.
If the IT rep. can run MapInfo Pro without error, then the user's Windows profile should be adjusted accordingly by IT.
If Pro throws the error, go to Control Panel > Admin Tools > Services
and make sure the FLEXNET services are installed, started and set to "automatic".
It may be helpful to have an IT rep. log on as the Local Machine Admin and test MapInfo Pro.
If the IT rep. can run MapInfo Pro without error, then the user's Windows profile should be adjusted accordingly by IT.