Product: Spectrum Server SP2 Client Tools OS: Windows and Linux
Issue
When downloading the Client Tools installer from the Spectrum server web page, depending on system and browser settings, it may save the installer as a .zip file. When trying to extract the .zip file you will get an error saying the file is corrupted or is not a valid zip file.
Cause
As part of several deployments recently, I’ve observed the following behavior when attempting to deploy the Client Tools. Download differs from expectations:
a. The referenced web page (http://:) includes a link titled “Client Installers” with a link to :/managers/PlatformConfiguration/Exports/Setup.exe .
b. When following this link, the downloaded file that results is called “Setup.exe.zip”.
c. The ‘.zip’ extension leads a user to believe that they must first decompress the file – but if you do this, the resulting setup.exe will not run.
a. The referenced web page (http://:) includes a link titled “Client Installers” with a link to :/managers/PlatformConfiguration/Exports/Setup.exe .
b. When following this link, the downloaded file that results is called “Setup.exe.zip”.
c. The ‘.zip’ extension leads a user to believe that they must first decompress the file – but if you do this, the resulting setup.exe will not run.
Resolution
UPDATED: August 23, 2017Change the browser you use to connect to Spectrum Server webpage, or simply rename the .zip to an .exe file and the installer will run correctly as expected.