VERIFIED SOLUTION i

'Sagent CSaXMLGetBlob::OnDataAvailable: Exception' message in Sagent

Product Feature: Weblink Server


 

Issue

 'Sagent CSaXMLGetBlob::OnDataAvailable: Exception' is observed while executing a plan in Sagent Web Link Server.

Cause

This could be caused if the output of the plan to be shown on the Web Browser is considerably large.

Resolution

UPDATED: September 17, 2019
Make following changes to the registry keyS under [HKEY_LOCAL_MACHINE\SOFTWARE\Sagent\DataMart\IT] on the machine where Sagent Web Link server is hosted.
  • Increase the SaFileCacheSize, example = 150000
  • SaUseFileCache = OFF
  • Set SaBlobLimit: 0 / SABLOBLIMIT does not exist by default and needs to add it as STRING with value 0
Restart Sagent Web Link and Data Flow Server.