VERIFIED SOLUTION i

MapInfo Pro and problems connecting with Oracle Spatial on Windows 7 vs. Windows XP

Product Affected: MapInfo Pro™
 

Issue

User running MapInfo Pro (any version) on Windows XP can connect to Oracle Spatial Server but when Pro is installed on Windows 7, an error message is displayed: "Oracle Error: ORA-12154: TNS: could not resolve the connect identifier specified"

Cause

The problem is occurring because on Windows 7, Oracle places the "sqlnet" and "ntnsnames" files in a different location as compared to Windows XP.

Resolution

UPDATED: December 3, 2019
To resolve this issue, make sure the Oracle Client is installed BEFORE MapInfo Pro is installed:

1. Make sure that the Oracle client is installed first.

2. Place the "sqlnet" and "tnsnames" files in the correct folder – this location changed for Windows 7 to
    C:\Oracle\Product\11.2\Clien_1\network\Admin

3. Install MapInfo Pro.