VERIFIED SOLUTION i

Resolving error "(4088) The license server manager (lmgrd) failed to open the TCP/IP port number" in Mapinfo Service

Products affected: MapInfo Pro™
 

Issue

When Mapinfo Licence Server (FlexNet Licencing Service) is installed on the same licence server (VM) as the EncomLM (Encom Licencing Service) Server, the mapinfo client will give an error on startup that the Licence Server failed to open the port.

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Cause

The problem is a conflict between the services for EncomLM and FlexNet .

A symptom is the LSU being in the not running status when started although the service is running from the service.msc.

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Resolution

UPDATED: December 3, 2019
The solution is to start the Mapinfo Service prior to starting the FlexLM service on the server. If you add a delay into the timing of the FlexLM service, the service starts and the Mapinfo client can then retrieve the licence from the server.