Resolve "Fatal error: A newer version of the Spectrum Technology Platform installer was used to install the existing Platform. Installer cannot continue" when installing Spectrum v9


 

Issue

User receives "Fatal error: A newer version of the Spectrum Technology Platform installer was used to install the existing Platform. Installer cannot continue." when installing Spectrum v9.

Cause

Upgrading from 9 Early Release to 9 GA is not supported.

Resolution

UPDATED: October 23, 2017
What IS supported is manually exporting all dataflows as .df files and process flows as .pf files from the Early Release, uninstalling the Early Release, installing the final release, and then importing all dataflow .df files and process flow .pf files in the final release.

But even if the User does this, they will lose all configuration such as module database resources, JDBC connections, execution history, etc.