Product Feature: Web Service (API)
Issue
Delivery problem in EngageOne 3.0.4 with GEN2 AND OpenEDMS workflow
The function searchDeliveryItems only returns composed items if the current user was the user who approved/submitted it to the delivery service.
The user who "approves" the submitted work item will be the only person who can retrieve the composed delivery item with "searchDeliveryItems". The creator cannot retrieve the delivery item. If they attempt to use "searchDeliveryItems" with the specific Work Item ID, they will get the error: "Delivery item(s) not found".
This will not be apparent in the included user interface, Interactive Correspondent, since Correspondent uses Gen1 API calls internally.
The function searchDeliveryItems only returns composed items if the current user was the user who approved/submitted it to the delivery service.
The user who "approves" the submitted work item will be the only person who can retrieve the composed delivery item with "searchDeliveryItems". The creator cannot retrieve the delivery item. If they attempt to use "searchDeliveryItems" with the specific Work Item ID, they will get the error: "Delivery item(s) not found".
This will not be apparent in the included user interface, Interactive Correspondent, since Correspondent uses Gen1 API calls internally.
Cause
This is a defect in EngageOne 3.0.x and earlier, and 3.1 builds before 3.1.0.9-build-26.
Resolution
UPDATED: November 13, 2017The problem was fixed in 3.1.0.9-build-26. To resolve the problem, upgrade to this build or later.
Workaround:
The only workaround is to use the "reviewer" user, who approved the Work Item when calling the searchDeliveryItems() API call.
Workaround:
The only workaround is to use the "reviewer" user, who approved the Work Item when calling the searchDeliveryItems() API call.