AutoMate BPA - Access Violation with send mail action

Product Feature: Actions


 

Issue

AutoMate BPA - Access Violation with send mail action

Cause

A customer of ours is getting the following error when adding a Send Mail"-Action in the Task. The error then pops up 20-30 times. 
How can this be resolved? 

Resolution

UPDATED: December 27, 2017
On the server where BPA 9 is installed you could remove the Task Builder folder from the Windows Registry. Follow these instructions exactly: 
1 Close BPA 9, SMC, Workflow Designer and Task Builder if open. 

2 Within Windows Services.msc, STOP these services in this order: AutoMate BPA Server 9 Agent AutoMate BPA Server 9 Management Server AutoMate BPA Server 9 Execution Server 

3 Type regedit from the Run command. Backup the registry to the Desktop Navigate to HKEY_CURRENT_USER\Software\Network Automation\AutoMate BPA Agent 9\TaskBuilder Delete the Task Builder folder from the registry. 

4 Within Windows Services.msc, START these services in this order: AutoMate BPA Server 9 Execution Server AutoMate BPA Server 9 Management Server AutoMate BPA Server 9 Agent 

5 Open BPA 9 SMC and edit the Workflow in question. Test the Send Email Action