Error upgrading from MapXtreme version 7.1 to 7.2

Product Feature: Installation / Upgrade


 

Issue

After upgrading from MapXtreme version 7.1 to 7.2, a series of errors occur that he had seen before:

"The program can't start because NCSEcw.dll ismissing from your computer."
"The program can't start because lti_dsdk.dll is missing from your computer."
"The program can't start because leadtoollicensing.dll is missing from your computer."

Cause

"The program can't start because NCSEcw.dll ismissing from your computer.", "The program can't start because lti_dsdk.dll is missing from your computer.", and "The program can't start because leadtoollicensing.dll is missing from your computer." are attributed to missing files after the upgrade.
 

Resolution

UPDATED: August 24, 2017
The error related to "NCSEcw.dll missing" is from ecw4.rhd file. This dll is located at following location
For 32 bit installation:
"C:\Program Files (x86)\Common Files\Mapinfo\Mapxtreme\7.2.0\RasterGridHandlers"
64 bit installation:
"C:\Program Files\Common Files\Mapinfo\Mapxtreme\7.2.0\RasterGridHandlers"

Remaining workarounds:
1. Is ORACLE is installed on the system? If yes then in "PATH" Environment variables add best suited path of "RasterGridHandlers" before oracle path. This is known problem of MapXtreme with Oracle.
2. Install MapXtreme 7.2 on a fresh machine and change the assemblies references to MXT 7.2.
3. Try to copy "NCSEcw.dll" from above mentioned path and placed it with .exe location.