"We are unable to validate your license due to error -5" when trying to connect to the MapInfo Pro license server utility (LSU)

Products affected: MapInfo Pro™, MapInfo License Server Utility™.

Issue

When trying to connect MapInfo Pro to the License Server Utility (LSU), for license activation, the following error message is encountered:

We are unable to validate your license due to error -5.

The default PORT of 27000 is open.

Cause

The main cause for this error is when the latest version of the License Server Utility is not being used. When MapInfo Pro is upgraded then the latest version of the LSU should also be downloaded and installed.

Other possible causes of this error are:
  • Migrating the PC or VM where the LSU is installed to a new physical location.
  • Moving the LSU to a new PC or new VM.

Resolution

UPDATED: March 9, 2020
Solution 1: Upgrade the LSU to the latest version.  You can retrieve the latest LSU version and documentation here

Solution 2: Open the original LSU (make sure all borrowed license seats are returned) and transfer license seats back to Pitney Bowes. Then install the LSU on the new PC or at the new location and reactivate the license seats.