Issue
This issue has been seen after upgrading to Dialogue 6.0 SP1, because of changes to our webservice URL.
When performing an Email Test in Visual Dialogue, the following Error:
When performing an Email Test in Visual Dialogue, the following Error:
There was no endpoint listening at https://pd.pbs-cloud.com/MHExternalServices/EmailUtilitiesService.svc that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present,
Cause
This issue has been seen after upgrading to Dialogue 6.0 SP1, because of changes to our webservice URL starting with this version.
Resolution
UPDATED: October 10, 2019The first thing to do is to make sure that everything is OK with Litmus.
They have a website for this purpose: https://status.litmus.com/
If Litmus is experiencing problems, then all you can do is wait it out.
If everything is OK on the Litmus site, then there are a few things you can check.
They have a website for this purpose: https://status.litmus.com/
If Litmus is experiencing problems, then all you can do is wait it out.
If everything is OK on the Litmus site, then there are a few things you can check.
- Connectivity and access:
- Dialog server (COM+ user) must have access to https://pd.pbs-cloud.com/
- Visual Dialog must have access to both https://pd.pbs-cloud.com/ and http://litmus.com to show results of the Litmus report (it is an HTML page at https://pd.pbs-cloud.com/ and have content/picture from http://litmus.com)
- Increase timeout:
- Open the file "C:\Program Files (x86)\PST\Million Handshakes\Dialog Server\DialogServerPlugins\ExternalServices\ExternalServicesPlugin.dll.config"
- In the "Binding" section you will find 4 different timeout settings, which you can revise to suit your requirements.
- closeTimeout="00:01:00"
- openTimeout="00:01:00"
- receiveTimeout="00:10:00"
- sendTimeout="00:01:00"