'connect to database failed' message in EngageOne Vault

Issue

ODBC Export fails with following error:
exporting [docdata\20140407090648_provr835its_series5a.drd] to [DocumentRepository] 
table[tblDoc1ArchiveUpload] 
0 10 20 30 40 50 60 70 80 90 100 
| | | | | | | | | | | 
EXPORT: connect to database failed, [IM014] [Microsoft][ODBC Driver Manager] 
The specified DSN contains an architecture mismatch between the Driver and Application

 

Cause

This can be caused by using 64-bit of ODBC setup with EngageOne Vault.

Resolution

UPDATED: January 8, 2020
Ensure the 32-bit ODBC setup is being used with EnagageOne Vault as EngageOne Vault is a 32-bit application.